Saving and Restoring Sessions

In this topic:


You can save the current session for later restoration. This is useful in the situation where you are in the middle of editing schematics or studying simulation results, but you need to interrupt this work maybe at the end of a working day. While in some situations you might simply be able to leave your computer switched on and logged in, or maybe use a "Hibernate" mode, these methods are not always practical or indeed reliable.

The SIMetrix save session feature will save the current state of all open schematics, all open graphs and any simulation data so that it can be restored at a later time.

Saving a Session

Select menu File > Save Session.

Restoring a Session

You can only restore a session if all graphs and schematics are closed and there is no current simulation data loaded. This is the normal state when SIMetrix has just been started. If you wish to restore a session when SIMetrix has been in use since first starting, you can either shut down and restart, or close all windows and graphs then delete all data groups. To delete all data groups, select menu Simulator > Manage Data Groups..., then click on Delete All Groups and Ok.

To restore the session, select menu File > Restore Session

Where is Session Data Stored?

Session data is stored in the following directory:


where application_data is the SIMetrix application data directory. See Application Data Directory for details.