Options

In this topic:

Overview

There are a number of options affecting all aspects of SIMetrix. Many of these may be viewed and adjusted using the Options dialog box, others can only be accessed from the command line using the Set and Unset commands.

Using the Options Dialog

This is invoked with the menu File > Options > General.... This brings up the following:

Schematic Sheet

Undo Level Number of levels of schematic undo. See Creating a Schematic.
Most Recent Files Controls how many recently used files are displayed in the File | Reopen menu
Bias Annotation Precision Controls the precision of the schematic voltage and current bias annotation markers.
Auto-save interval (minutes) Enter a value to enable schematic auto-save. SIMetrix will automatically save a backup copy of your schematic at the interval specified. If SIMetrix aborts abnormally, perhaps due to a power failure, you will be prompted to recover the auto-saved schematic when you next start SIMetrix.
Hierarchy Highlighting Check the Disabled box to disable highlighting through the hierarchy. With deep and complex hierarchies, net highlighting can be time-consuming. Checking this box will restrict highlighting to the current schematic only.
Double click mode Selects action when double clicking a schematic instance. Select Classic to retain pre version 5.0 behaviour whereby double clicking always starts a new wire. Select Edit selected part for the default behaviour which is to invoke the device value editor.

Property Editing
Enable GUI Property Edits: If checked, allows property text (i.e. labels) to be moved using mouse actions. Labels themselves can be editted by double clicking. See Notes on Property Text Position before checking this option.
Placement When to auto-repeat placement of schematic parts. If autorepeat is enabled, a new symbol to be placed is automatically displayed after each placement. This speeds the placement of many instances of the same device.
Wiring Enable smart wiring enables the smart wiring algorithm. See Wiring for details about smart wiring.

Allow route through connected is an option for the smart wiring algorithm that allows it select routes that pass through existing wires that are already connected to the source or target destinations.
Grid Option to hide the schematic's grid.
Initial Simulator This is only relevant for SIMetrix/SIMPLIS products. Sets the initial simulation mode when opening a new schematic. If most or all of your work is with SIMPLIS, check SIMPLIS. This will save time switching to SIMPLIS mode for all new schematics.

Graph Printing

Axis line width Width in mm of printed axis.
Grid line width Width in mm of printed grid lines.
Minor grid Width in mm of printed minor grid lines.
Curve line width Width in mm of printed curves.
Curve identification When printing on monochrome printers or if Use markers for colour is selected, curves are differentiated using different line styles (solid, dashed etc.) and marker shapes (circles, squares etc.). For a large number of curves both methods are used but for just a few you can use this option to state your preference.
Prefer line styles printed curves will first be differentiated using line styles.
Prefer curve markers Printed curves will first be differentiated using curve markers.
Use markers for colour Even if printing to a colour printer, curves will still be printed using markers and variable line styles to differentiate them. They will also be printed in colour. This is useful when creating on-line documents (e.g. using Adobe Acrobat Distiller) which might subsequently be viewed on-line or printed out.

Graph/Probe/Data Analysis

Probe update times Plots created from fixed probes are updated on a regular basis. This controls how frequently and when it starts.

Period: Update period in seconds.

Start: Start delay in seconds.
Fixed probe global options Default persistence: Sets the default persistence for fixed probes. This is number of curves from previous simulations that remain after a simulation. If set to 1, previous results are deleted. If set to zero all results are retained. Persistence can also be set individually for each probe. See Probe Options Sheet for details.
Sizes
Curve weight Thickness of displayed curves. Curves display much quicker if this value is set to 1 but are clearer (but can lose detail) if set to 2.
Digital Axis Height Sets height of axes (in mm) used to plot digital traces.
Min grid height When a grid is added to a graph window, existing grids are reduced in height to accommodate the new one. But they won't be reduced to a height lower than specified by this setting. When this limit is reached, the vertical space will be increased by allowing the window to scroll.
Temporary data file delete Simulation data is stored in data files that are placed in the temporary data directory (see file locations below). These options control when these data files are deleted.
Never Temporary files are never deleted but will be overwritten in subsequent sessions. Not recommended unless you only ever do short simulations.
When SIMetrix starts All temporary files are deleted when SIMetrix starts.
When SIMetrix closes All temporary files are deleted when SIMetrix is shut down. While using SIMetrix, you can recover earlier simulation runs. Normally, only the 3 most recent are kept but earlier ones can be recovered from the TEMPDATA directory using File > Data > Load....
When data is no longer needed This is the most aggressive delete method and is recommended if you do many long runs or/and have limited disc space. By default, the 3 most recent runs are kept but with the other options above, the data files are not deleted when the data is not needed but links to the data in them are released. (See explanation below). If this option is set, the data files are deleted as soon as they become out of date, optimising use of disc space at the expense of not being able to recover old data.

Graph placement
Specifies how new graph sheets are created.
Split Splits current view to create a new graph view on the right hand side
New window Creates a new graph main window if one does not already exist
Overlay Overlays the graph sheet over existing views

Histogram style
Controls the curve style used for histogram displays:
Stepped Displays a flat line for the width of each bin. Similar to a bar graph.
Smooth Joins the centre of each bin with a straight line to display a continuous curve.
Cursor readout Controls where cursor values are displayed.
On graph Values are displayed on the graph itself.
Status bar Values are displayed in status bar boxes at the bottom of the graph window.
Both Displayed in both locations as described above.

How data is stored

Simulation data is stored in temporary data files as explained above. The data is not read into system memory until it is needed - say - to plot a graph. However, the location in the file of the various vectors is always in memory so that the data can be extracted from the file as rapidly as possible. It is this latter location data that is destroyed when a simulation run gets out of date. The file containing the data gets deleted at a time set by the above options, not necessarily when the data is no longer needed. As long as the file exists, the data can be recovered by calling File > Data > Load... or File > Data > Load Temporary Data... which re builds the location data.

Miscellaneous

Library Diagnostics Determines whether messages are displayed when models are found in the library.
Action on unknown model parameter Specifies action to be taken when an unknown model parameter is encountered. There are three options:
Abort simulation an error will be raised and the simulation will be aborted.
Issue warning a warning message will be output to the list file but the simulation will continue normally.
Ignore no warning or error will be raised and the simulation will continue normally.
Script Options
Echo all messages If set, all script lines will be displayed in the message window. This will result in a great deal of output and will slow down the whole program operation. Only set this if you are debugging your own scripts.
Don't abort scripts on error Normally scripts abort if an error is detected. Check this box to disable this behaviour.

File Locations

Locations in your files system of various files and folders needed for correct operation of SIMetrix.

Built-in Scripts This is the first location that SIMetrix searches for scripts. Much of the user interface is implemented with scripts and these are all internal to the program. These can be overridden by placing scripts of the same name at this location. This allows modification of the UI. Changing this setting has no effect until you restart SIMetrix.
Scripts Location of script directory. This directory is searched for any scripts you run. Only change this setting if you are actually moving the script directory. Changing this setting has no effect until you restart SIMetrix.
Start up Current working directory on start up.
Start up Script Name of script that is automatically run on startup. You can place custom menu or key definitions in this file.
System Symbols Location Directory location where the standard symbols are located.
Temp Data Location of temporary simulation data files. Changing this setting has no effect until you restart SIMetrix. Note that this should always be a local directory. That is, it must not be on a remote network partition.
User Symbols Location Directory where user symbol libraries are expected to be located. Note, you can place symbol libraries anywhere. This directory is simply a location that some UI functions use as a default.

File Extensions

Defines extensions used for the various files used by SIMetrix. These setting control what file extensions are listed for editors of the various file types and, where relevant, what action will be taken if a file of that type is dragged and dropped into the SIMetrix environment.

Many SIMetrix file types use five letter extensions beginning with .sx. This is to help prevent clashes with other applications.

For each setting, the supported extensions are separated by a semi-colon. The first in the list is the default. So, for example, the default schematic extension is sxsch so when you save a schematic without giving an extension, it will automatically be given the extension sxsch.

Schematic Files Extensions used for schematic files.
Data Files Extensions used for simulation data files.
Text files Supported extensions for text files.
Symbol Files Extension used for binary schematic symbol files. This is used by the drag and drop system to detect Symbol Library files being dropped into the command shell.
Logic Def. Files Files used for logic definitions for the digital simulator's arbitrary logic block. If the extension is omitted in the model (FILE parameter) this will be used.
Scripts Default extension for scripts if called without an extension.
Device models SPICE model files. Used by drag and drop system to detect model file types. Note the drag and drop system will detect model files with extensions not in this list and it is not usually necessary to specify model file types here.
Netlist Files Files used for simulation netlists.
Schematic Components Extensions used by schematic component files.
Verilog-A Files Verilog-A Source files.
Verilog-HDL Files Verilog-HDL Source files.

Text Editors

Defines colour syntax highlighting for the various text editors.

Customisation

Defines colours for various UI elements. Note that schematic elements are defined using schematic styles.

Elements are divided into these groups:
Command Shell Command shell text and background colours. Command shell input is the command line at the top, while command shell output is the message window below it
File View Colour elements of the file viewer
Part Selector Colour elements of the part selector
Graph Colour elements for graphs. This includes both text and graphic objects. Note that all text items are based on the Graph Text Colour object. Changing this object will also change the colour of the objects: Caption Colour, Free Text Colour, Text Box Text Colour, Legend Box Text Colour, Curve Marker Text Colour and Cursor Dimension Text
Curves Curve colours are chosen using a sequence number. The first curve on a sheet uses sequence 1, the second sequence 2 etc. New curves use the first unused sequence number. The colours associated with each sequence number can be defined here.

Using the Set and Unset commands

All options have a name and many also have a value. These are set using the Set command and can be cleared with Unset. When an option is cleared it is restored to its default value. A complete listing of available options with possible values is given below. Note that option settings are persistent. This means that their values are stored either in the .INI file or in the system registry (see Configuration Settings) and automatically restored at the start of each subsequent SIMetrix session.

List of Options

Upper and lower case letters have been used for the option names in the following listing only for clarity. Option names and their values are not in fact case sensitive. Many of the options described below are supported by the Options dialog box in which case they are noted accordingly.

Unsupported Options

Some options in the following list are marked as 'unsupported'. This means that they may be withdrawn in the future or their functionality changed.

Name Type Description User
700Extensions Boolean Schematic symbols for the 700 series semi-custom arrays are enabled if this is set.
ActionOnMissingModel string Default=AutoAssociate

Action to be performed when attempting to place a model from the library, but that model has not been associated. If set to AutoAssociate, will attempt to auto-associate by simulating the model
AllowTempDataDrives String List of drives separated by commas which are allowed to be used for simulation data without triggering a warning message. Drive should be specified with ':' suffix - e.g Y:. A warning message will be issued for any drive that is reported as connected through a network if used for simulation data storage. Only use this setting to override drives that are reported as network drives but in fact are connected locally.
AlwaysUseMarkers Boolean Graphs are printed with markers even for colour printers. Options

dialog
AnnoMinSuffix Numeric Default = 1

Minimum suffix used for automatic generation of schematic part references

AutoStartWire
Boolean Default=False

Only effective if AutoWireEnabled is False.

Selects mode whereby a wire is started when the cursor is brought close to a pin or wire termination. This mode is on automatically when AutoWireEnabled is True
Options

dialog
AutoWireEnabled Boolean Default=True

Smart wiring is on if this is True
Options

dialog
AWAllowRouteThruConnected Boolean Default=True

Controls whether the smart wire algorithm is allowed to route wires through existing wires that connect to the destination or target
Options

dialog
AxisPrintWidth Numeric Default = 0.5

Width of printed axis in mm. See also CurvePrintWidth and GridPrintWidth
Options

dialog

AutoSaveInterval
Numeric Default=0 meaning disabled. Interval in minutes for which the session is automatically saved in order to recover from an unexpected program exit Options dialog
BiasAnnoPrecision Numeric Default=6

Precision of values displayed for schematic DC bias annotation
Options

dialog
BiScriptDir Text This is the first location that SIMetrix searches for scripts. See File Locations section of Options

dialog above for more info.
Options

dialog
BuildAssociations Text Default=ask

See Auto Configuration Options
BuildModelLibs Text Default=ifempty

See Auto Configuration Options
BuildPreferenceSettings Text Default=askmigrate

See Auto Configuration Options
BuildSymbolLibs Text Default=ifempty

See Auto Configuration Options
CachePathSymbols unsupported Boolean Default=false

If true, SIMetrix will cache symbolic paths

ComponentExtension
Text Default=sxcmp

File extension for schematic component files
Options

dialog
CursorDisplay Text Default = Graph. Controls initial graph cursor readout display.
Graph Display on graph only
StatusBar Display on status bar only
Both Display on both graph and status bar
Options

dialog
CurvePrintWidth Numeric Default = 0.5mm Width of printed graph curves in mm. See also GridPrintWidth. Options

dialog
CurveWeight Numeric Default = 1 Sets the line width in pixels of graph curves. Note that although widths greater than 1 are clearer they normally take considerably longer to draw. This does however depend on the type of adapter card and display driver you are using. Options

dialog
DataExtension Text Default=sxdat;dat

Default file extension for data files
Options

dialog
DataGroupDelete Text Default = OnStart Determines when temporary simulation data is deleted. Possible values, Never, OnStart, OnClose and OnDelete. See Graph/Probe/Data Analysis for details. Options

dialog
DefaultLib Text Default=%SHAREPATH%/SymbolLibs/default.sxslb

Name and location of default symbol library
DefaultPersistence Default=0

Sets the number of curves that are kept for graph fixed probes. '0' means that all curves are kept. '1' means that only 1 is kept at a time.
Options

dialog
DevConfigFile Text Default=%SHAREPATH%/DeviceConfig.cfg

Name and location of device configuration file. See Simulator Reference Manual for details
DigAxisHeight Numeric Default = 8.0mm Height of digital axis in mm. (Screens are typically 75pixels/inch) Options

dialog

DisableCurveDataCompression
bool Default=FALSE Set to TRUE to disable curve point compression. This generally speeds up graph drawing but can introduce minor artefacts No

DisplaySimProgressMessage
Boolean Default=False

If true, a message will be displayed in the command shell indicating the start and end of a simulation
EchoOn Boolean When set, all commands are echoed to the command shell message window. This is used primarily for script debugging. Options

dialog

EnableFileChangeWatcher
bool Default=TRUE The GUI monitors changes to files and prompts the user to reload when changes are detected. Set this to FALSE to disable No
EnableFileChangeWatcher

FileView
bool Default=TRUE The file viewer monitors changes to files and updates if changes are detected. Set to FALSE to disable this behaviour No

EnableLWEditMenu
bool Default=FALSE Enables the schematic popup menu Edit MOS Length/Width... which edits the length, width and multiplier (M) for MOSFETs used in IC design      

ExportRawFormat
Text Default = SPICE3 Possible values, SPICE3, SPECTRE and OTHER. Controls format of raw output. See Exporting SPICE3 Raw Files No

ForceGlobalHash
Boolean Default=false

In the simulator, any node name found in a subcircuit that starts with a '#' accesses a top level node of the same name but without the '#'. E.g. #VCC in a subcircuit connects to VCC at the top level.

If this option is set, the '#' is not stripped, so #VCC in a subcircuit connects to #VCC at the top level.

GraphExtension
Text Default=sxgph

File extension used for graph files
Options

dialog

GraphLegendMaximum

HeightProportion
real Default=0.25 Maximum height of the graph legend window as a proportion of the graph window height

GraphPlacement
string Default=split.

Selects how new graph windows are created. Has one of three values
Split Splits current layout and places graph on the right side
NewWindow Creates a new main window for graphs if one does not already exist
Overlay Overlays graph windows over the top of existing windows

Options

dialog
GridPrintWidth Numeric Default = 0.3mm Width of printed graph grid lines in mm. See also CurvePrintWidth Options

dialog
GroupPersistence Numeric Default = 3 Sets the number of groups that are kept before being deleted. See Plotting the Results from a Previous Simulation No
GuiEditPropertyEnabled Boolean Default=false

If set, allows visible properties in the schematic to be edited using GUI actions.
Options

dialog
HideSchematicGrid Boolean If set, the schematic grid will be suppressed Options

dialog

HistoAdvancedStats
bool Default=FALSE Display advanced statistics in histogram plots Performance analysis dialog

HighlightIncrement
Numeric Default = 1

Highlighted graph curves are thicker than normal curves by the amount specified by this option
No
HistoCurveStyle Text Default=stepped

Sets histogram curve style
Options

dialog

InitSchematicSimulator
Text Default=SIMetrix

Simulator mode for new schematic. If set to SIMPLIS, all schematics will start in SIMPLIS mode. Otherwise they start in SIMetrix mode
Options

dialog
InterpOrder Numeric Default=2

Sets interpolation order for the FFT calculation used for distortion measurements
InterpPts Numeric Default=1024

Sets number of interpolated points for the FFT calculation used for distortion measurements
InvertCursors Boolean Default=false

If true, schematic and graph mouse cursors are modified to be suitable for use on a black background
LibraryDiagnostics Text Default = Full

Possible values, Partial, None and Full. Affects progress information displayed during model library searching.
Options

dialog
LicenseDisableFast Checkout Boolean Default=false

Affects network licenses only. If set, the license checkout process may take longer delaying the time it takes SIMetrix to start.
LogicDefExtension Text Default=ldf

File extension used for logic definition files
Options

dialog

MaxHighlightColours
Numeric Default=4

Maximum number of different colours used for schematic highlighting
MaxVectorBufferSize Numeric Default=32768 See the Simulator Reference Manual for a full explanation
MinGridHeight Numeric Minimum allowed height of graph grid Options

dialog
MinorGridPrintWidth Numeric Default=0.05

Print width in mm of graph's minor grid
Options

dialog
ModelExtension Text Default=lb;lib;mod;cir

File extensions used for model files
Options

dialog
MRUSize Numeric Default = 4 Number of items in File | Reopen menu. Options

dialog

NewModelLifetime
Numeric Default=30

Number of days that user installed models remain displayed in the '* Recently Added Models *' model library browser category
NoEditPinNamesWarning

unsupported
Boolean Default=false

If true, the warning given when using the Edit Pin Names button in the associate models dialog box is inhibited
NoHierarchicalHighlighting Boolean Default=false

If set hierarchical schematic highlighting is disabled. That is, if you highlight some part of a hierarchical schematic, only that schematic will be highlighted with no propagation to parent or child schematic

NoKeys
Boolean If on, the default key definitions will be disabled. Note this will not take affect until the next session of SIMetrix. Options

dialog
NoMenu Boolean If on, the default menu definitions will be disabled and no menu bar will appear. This will not take affect until the next session of SIMetrix. Options

dialog
NoStopOnError Boolean If disabled, scripts and multi-command lines (i.e. several commands on the same line separated by ';') are aborted if any individual command reports an error. Options

dialog
NoStopOnUnknownParam Text Specifies action to be taken in the event of an unknown parameter being encountered in a .MODEL statement. Choices are:

TRUE: No action taken, simulation continues normally FALSE: An error will be raised and the simulation will abort WARN: A warning will be displayed but the simulation will continue

This will be overridden by a .OPTIONS setting of the same name. Refer to Simulator Reference Manual/Command Reference/.OPTIONS for details
Options

dialog

OmitAsciiRevision unsupported
Boolean Default=false

If true, the revision value is not written to ASCII schematic files. For backward compatibility.
No

PartSelShowSimplisModels
Boolean Default=False

If true, model library parts will show directly in the part selector in SIMPLIS mode
No
PartSelShowSimetrixModels Boolean Default=True

If true, model library parts will show directly in the part selector in SIMetrix mode
No
PassUnresTemplate unsupported Boolean Default=false

If true, unresolved template values in netlists will be passed literally. Default behaviour is no output
No
Precision Numeric Default = 10

Precision of numeric values displayed using Show command.
No
PrintOptions Text Options set in print dialog Print

dialog
PrintWireWidth Numeric Default=5 Width in pixels of schematic wires when printed No
ProbeFlushOnUpdate Boolean Default=false

It is not usual to need to set this option. Simulation data is buffered for performance reasons but this buffering can interfere with the incremental updates needed for fixed probes. Usually SIMetrix deals with this problem automatically but this is not guaranteed to work in all cases. In such situations, fixed probes or .GRAPH statements may not incrementally update correctly. Setting this option may rectify this.
ProbeStartDelay Numeric Default = 1 Delay after start of simulation run before fixed probe graphs are first opened. Options

dialog
ProbeUpdatePeriod Numeric Default = 0.5 seconds Update period for fixed probe graphs Options

dialog
PSpiceIniPath Text Path of PSPICE.INI file needed for the PSpice 'Schematics' translator. Options

dialog
RebuildConfig Boolean Default=true

See Auto Configuration Options
No
RepeatPlace Text Default = Toolbar

Controls when schematic placement is repeated. Possible values, Always, Toolbar (toolbar symbols only) and Never.
Options

dialog

SchematicReadOnly
Boolean Default=false

If set all schematics are opened in read only mode
No
SchemDoubleClickScript Text Default=on_schem_double_click /ne

Script that is called when a double click action is detected in the schematic. Only active if SchematicEditMode= NoSnap
ScriptDir Text Default=%SXDOCSPATH%/Scripts

%SXDOCSPATH% is "My Documents/SIMetrix"

Directory used to search for scripts and symbol files if not found in the current directory. Changes to this option do not take effect until next session.
Options

dialog
ScriptExtension Text Default=sxscr

File extension used for scripts
Options

dialog
ShellCommandProcessor Text String used to launch command processor when /command supplied with "Shell" script command. See Shell command in the Script Reference manual for more details
SHOWWELCOMEPAGE Boolean Default=true. If set a welcome page will be displayed on first start Welcome page
SimDataGroupDelete Text Default=Never

Same as DataGroupDelete when simulator is run independently. I.e. not called from the front end
No
SIMPLISPath Text Default=%EXEPATH%/simplis.exe

Path of SIMPLIS binary
No
SnapshotExtension Text Default=sxsnp

File extension used for snapshot files

StartUpDir
Text Current directory set at start of session. Options

dialog
StartUpFile Text Default = Startup.SXSCR Script that is automatically run at start of each session. Options

dialog
StatusUpdatePeriod Numeric Default = 0.2 seconds Minimum delay in seconds between updates of simulator status window during run. No
SymbolExtension Text Default=sxslb;slb

File extension used for symbol files

SymbolsDir
Text Default=%SHAREPATH%/SymbolLibs

Path of directory where system symbol libraries are located.
Option dialog

SystemStyle
Text Default=LightStyle.qss. Sets the style sheet that defines the user interface style. May be set to DarkStyle.qss or custom generated style sheet placed in support\ ui File > Options > Interface Colour...
TempDataDir Text Default = %TEMPPATH%/ SIMetrixTempData

See Default Configuration Location for definition of %TEMPPATH%

Directory where temporary simulation data files are placed.
Options

dialog
TextExtension Text File extension used for text files
TotalVectorBufferSize Numeric See the Simulator Reference Manual for a full explanation

TitleBlockDefaultAuthor
Text The default authour for title blocks Title block interface
TitleBlockDefaultCompany Text The default company name for title blocks Title block interface
TitleBlockDefaultLogoPath Text The path of the default logo for title blocks. Should be a bitmap file such as .jpg, .png, .bmp or .gif Title block interface

ToolBarIconSize
Numeric Default = 20. Size of toolbar icons in pixels. Takes effect on restart No

TranscriptErrors
Boolean Default=false

If true, incorrectly typed commands will be entered in the history box. (The drop down list in the command line that shows previously entered commands)
UndoBufferSize Numeric Default = 10

Number of levels of schematic undo. See Creating a Schematic
Options

dialog
UpdateClosedSchematics Boolean Allows SIMetrix to write to closed schematic if required. See Closed Schematics  
UpdateCurvesNoDeleteOld Boolean Default=false

If true, old curves are not deleted when using the Update Curves feature.
Plot | Update Curve Settings
UpdateCurvesNoFixSelected Boolean Default=false

If true update includes selected curves when using the Update Curves feature
Plot | Update Curve Settings
UseAltGraphPrintStyles Boolean Determines method of differentiating curves on monochrome hardcopies. See Graph Printing Options

dialog
UseGreekMu Boolean Default=false

If true, the 'u' used to denote 10e-6 will be displayed as a greek $\mu$ in graph axis labels
No

UseLocalHelp
Boolean If set, the help system will use locally stored content. Note that the local content must be installed for this to work. Menu Help > Select Help Source... will automatically set this option and install local content if needed. Help > Select Help Source...
UserScriptDir Text Alternative location for user scripts. See Script Reference Manual/Script Language/Executing Scripts for more information No
UserSymbolsDir Text Path of directory where the user's symbol libraries are stored. Options

dialog
UserSystemSymbolDir Text Default=%sxappdatapath%/SysSymbols

Location of symbol libraries containing edits to system symbols
No
UseSmallGraphCursor Boolean Default=false

If true, a small graph cursor will be used instead of the full crosshair
Cursors | Cursor Style

VideoBufferTotalSize
Numeric Default=100000000 (100MBytes). The total memory allowed to be used for video buffers. The bitmap image of each schematic and graph window is buffered in memory. This allows for fast redraw when tabs are switched or when a window is exposed. Without this buffering, the windows need to be redrawn which in the case of graphs can be time consuming. The buffers consume memory and this setting specifies how much memory may be allowed to be used for the buffers (that is all buffers together, not each one). If all the buffers needed exceed this memory allowance, some windows will be released meaning that a redraw will be needed when that window needs to be displayed. No

VlDataPath
Text Default=%SXAPPDATAPATH%/veriloghdl

Location of Verilog-HDL files. Currently only the cache data is stored here
VlModuleCacheSize Numeric Default=1000

Maximum number of cache entries for Verilog-HDL module info cache
WarnSubControls Boolean Default=false

If true, a warning will be issued if unexpected simulator commands are found in subcircuits.
No

Text Editor Colour Options

The following options set colours for text editor elements. All of these can be set in the Customisation sheet in the options dialog. See menu File > Options > General....

Option name Editor Element
AsciiFileEditorDoubleQuoteStringColour Ascii File Editor Double quoted string
AsciiFileEditorSingleQuoteStringColour Ascii File Editor Single quoted string
AsciiFileEditorSubTypesColour Ascii File Editor Sub types
AsciiFileEditorTypesColour Ascii File Editor Types
AsciiFileEditorValuesColour Ascii File Editor Values
LogicDefinitionEditorCommentColour Logic Definition comment colour
LogicDefinitionEditorKeywordColour Logic Definition keyword colour
NetlistEditorCommentColour Netlist editor comment colour
NetlistEditorDoubleQuoteStringColour Netlist editor Double quoted string colour
NetlistEditorInstanceColour Netlist editor Instance colour
NetlistEditorKeywordColour Netlist editor keyword colour
NetlistEditorSingleQuoteStringColour Netlist editor Single quoted string colour
NetlistEditorSubCircuitColour Netlist editor Subcircuit colour (.SUBCKT and .ENDS)
ScriptEditorBIScriptColour Script Editor Built-in script colour
ScriptEditorCommandColour Script Editor Command colour
ScriptEditorCommentColour Script Editor Comment colour
ScriptEditorDoubleQuotedStringColour Script Editor double quoted string colour
ScriptEditorFunctionColour Script Editor Function colour
ScriptEditorKeywordColour Script Editor keyword colour
ScriptEditorStringColour Script Editor string colour
TextEditorBackgroundColour Plain text editor background colour
TextEditorFontColour Plain text editor Text colour
TextEditorHighlightColour Plain text editor highlighted colour
VerilogAEditorAnalogOperatorColour Verilog-A editor Analog operator colour
VerilogAEditorDoubleQuoteColour Verilog-A editor String colour
VerilogAEditorIntegerColour Verilog-A editor Integer colour
VerilogAEditorKeywordColour Verilog-A editor Keyword colour
VerilogAEditorMultilineCommentColour Verilog-A editor Multi-line comment colour
VerilogAEditorPreProcessorColour Verilog-A editor Pre-processor colour
VerilogAEditorRealColour Verilog-A editor Real value colour
VerilogAEditorRegularFunctionsColour Verilog-A editor Function colour
VerilogAEditorSingleLineCommentColour Verilog-A editor Singe line comment colour
VerilogAEditorSystemFunctionsColour Verilog-A editor System function colour
VerilogHDLEditorDoubleQuoteStringColour

Verilog-HDL editor
String colour
VerilogHDLEditorKeywordColour Verilog-HDL editor Keyword colour
VerilogHDLEditorMultipleLineCommentColour

Verilog-HDL editor
Multi-line comment colour
VerilogHDLEditorSingleLineCommentColour

Verilog-HDL editor
Single line comment colour

Other Colour Options

The following options set colours for various elements. All of these can be set in the Customisation sheet in the options dialog. See menu File > Options > General....

Option name Editor Element
ShellInputActiveHighlightColour Command Shell Input Active highlight
ShellInputBackgroundColour Command Shell Input Background
ShellInputHighlightedTextColour Command Shell Input Highlighted text
ShellInputInactiveHighlightColour Command Shell Input Inactive highlight
ShellInputTextColour Command Shell Input Input text
ShellOutputActiveHighlightColour Command Shell

Output
Active highlight
ShellOutputBackgroundColour Command Shell

Output
Background
ShellOutputHighlightedTextColour Command Shell

Output
Highlighted text
ShellOutputInactiveHighlightColour Command Shell

Output
Inactive highlight
ShellOutputTextColour Command Shell

Output
Input text
PartSelectorBackgroundColour Part selector Background colour
PartSelectorTextColour Part selector Text colour
GraphColourText Graph Text Colour (default graph text colour)
GraphColourSelectedText Graph Selected Text Colour
GraphColourCaption Graph Caption Colour
GraphColourFreeText Graph Free Text Colour
GraphColourTextBoxText Graph Text Box Text Colour
GraphColourTextBoxBG Graph Text Box Background
GraphColourLegendBox Graph Legend Box Text Colour
GraphColourCurveMarkerText Graph Curve Marker Text Colour
GraphColourCurveMarker Graph Curve Marker Line Colour
GraphColourRectangle Graph Zoom Box Colour
GraphColourCrossHair Graph Cursor Colour
GraphColourMajorGrid Graph Major Grid
GraphColourMinorGrid Graph Minor Grid
GraphColourBackground Graph Background
GraphColourAxis Graph Axis
GraphColourSelectedAxis Graph Selected Axis
GraphColourHighlightedCurve Graph Highlighted Curve
GraphColourCursorDimension Graph Cursor Dimension
GraphColourCursorDimensionText Graph Cursor Dimension Text
GraphColourCurve_1 Curves Curve 1 Colour
GraphColourCurve_2 Curves Curve 2 Colour
GraphColourCurve_3 Curves Curve 3 Colour
GraphColourCurve_4 Curves Curve 4 Colour
GraphColourCurve_5 Curves Curve 5 Colour
GraphColourCurve_6 Curves Curve 6 Colour
GraphColourCurve_7 Curves Curve 7 Colour
GraphColourCurve_8 Curves Curve 8 Colour
GraphColourCurve_9 Curves Curve 9 Colour
GraphColourCurve_10 Curves Curve 10 Colour
GraphColourCurve_11 Curves Curve 11 Colour
GraphColourCurve_12 Curves Curve 12 Colour
GraphColourCurve_13 Curves Curve 13 Colour
GraphColourCurve_14 Curves Curve 14 Colour
GraphColourCurve_15 Curves Curve 15 Colour
GraphColourCurve_16 Curves Curve 16 Colour
GraphColourCurve_17 Curves Curve 17 Colour
GraphColourCurve_18 Curves Curve 18 Colour
GraphColourCurve_19 Curves Curve 19 Colour
GraphColourCurve_20 Curves Curve 20 Colour

File Extension

The following options set default file extensions. See Options dialog for more details.

Option name Default value Description
AsciiFileEditorExtension sxsch;sxslb;sxcmp ASCII schematic and symbol files
ComponentExtension sxcmp Schematic component files
DataExtension sxdat;dat Data files
GraphExtension sxgph Graph binary files
LogicDefExtension ldf Arbitrary block logic definition files
ModelExtension lb;lib;mod;cir SPICE model files
NetlistExtension net;cir;deck;out Netlist files
SchematicExtension sxsch;sch Schematic files
ScriptExtension sxscr;txt Scripts
SnapshotExtension sxsnp Simulator snapshot files
SymbolExtension lib Binary symbol files
TextExtension txt;net;cir;mod;ldf;sxscr;lib;lb;cat Text files
VerilogAExtension va;vams Verilog-A files
VerilogHDLExtension v Verilog-HDL files

Toolbar Buttons

The buttons displayed on each of the standard toolbars are defined with an option variable - that is one for each toolbar. The value of the option consists of a series of semi-colon delimited button names. A complete list of button names and full information concerning user defined toolbars can be found in the Script Reference Manual/Applications/Creating Modifying Toolbars. The toolbar option variable names are listed below.

Option name Description
ComponentButtons Schematic parts in SIMetrix mode
SIMPLISComponentButtons Schematic parts in SIMPLIS mode
SchematicMainButtons Schematic main toolbar
SchematicFileButtons Schematic file operations toolbar
SchematicProbeButtons Schematic probe toolbar
SymbolMainButtons Symbol editor toolbar
SymbolFileButtons Symbol editor file operations toolbar
GraphMainButtons Graph window toolbar