Using the Schematic Editor

In this topic:

Creating a Schematic

The schematic editor has been designed to be intuitive to use and you may not need to read too much about it. Here we describe the less obvious procedures.If you have SIMetrix/SIMPLIS, make sure you are in the correct mode before entering a schematic. See above section.

In the following notes references are made to the schematic tool bar. The diagram above shows the standard toolbar and the function of each button.

To Place a Part

If it is a simple device which only needs a value such as a resistor or capacitor, select the appropriate symbol from the tool bar or Place menu. For other devices that require a part number, it is easiest to use the model library browser. Select menu Place > From Model Library and select your desired device.

To Change Value or Device Type for a Part

First select it then double click or select schematic popup Edit Part... or press F7. A dialog box appropriate for the type of part will be displayed. For devices requiring a model name, a list of available types will appear.

To Rotate, Mirror or Flip a Part

Use the Rotate toolbar button (see diagram above) or key F5 to rotate a part.

This operation can be performed while a part is being placed or while a block is being moved or copied (see below).

You can also select a part or block then press the rotate button/key to rotate in-situ.

To mirror a part or block through the y-axis, press the Mirror toolbar button or F6 key.

To flip a part or block (mirror about x-axis), press Flip button or press shift-F6.


There are a number of ways of placing a wire:

Method 1: Place the mouse cursor close to an unselected symbol pin or wire end. Notice the cursor shape change to depict a pen symbol. Now left click to mark the start point then left click again to mark the final point. SIMetrix will automatically route the wire for you. You can also mark intermediate points if you would prefer to define the precise route rather than accept the auto-routed connection.

Method 2: If you have a three button mouse or scroll wheel mouse you can start a wire by clicking the middle button/scroll wheel. Clicking the middle button or scroll wheel a second time will complete the wire and start a new one. Click the right button or press escape to terminate wiring.

Method 3: Start a wire by pressing F3 or double clicking the left button. Single clicking the left button will complete the wire and start a new one. Click the right button or press escape to terminate wiring.

Method 4: Press the Wiring tool button on the toolbar. You can start a wire by single clicking the left button, otherwise continue as described above. Press the Wire button again to cancel this mode.

Disconnecting Wires

In most cases just selecting the wire then deleting it with the delete key or button is the easiest way.

In some cases, especially if the wire is short, it is difficult to select it. In this instance, hold down the shift key then select area enclosing the wire. Press delete button.

To Move Items Disconnected

Select items then schematic menu Edit > Detach or the Detach toolbar button. Move items to desired location then press left mouse key. You can rotate/flip/mirror the items (see above) while doing so.

To Copy Across Schematics

Select block you wish to copy. Choose menu Edit > Copy. In second schematic choose Edit > Paste.

Multiple Selection

Individual items which do not lie within a single rectangle can be selected by holding down the control key while using the mouse to select the desired items in the usual way.

Selecting Wires Only

Hold down shift key while performing select operation.

Holding Down the ALT Key...

Zoom Area

Press the Zoom box button on schematic. Drag mouse to zoom in on selected area.

Zoom Full (Fit to Area)

Press the HOME key to fit the whole schematic in the current window size.